Note: Before upgrading, always ensure your server meets our latest minimum system requirements


Improvements


  • The Altaro VM Backup Daily Email report now includes timestamp details for when the listed operations have been run.

  • Exchange Item-level restore is now supported up to Exchange Server 2019 CU8.



Changes


  • Altaro VM Backup now requires .NET Framework 4.7.2 or higher in order to be installed.



Fixes


  • Fixes an issue that would cause the Backup Health Monitor to incorrectly report corrupted blocks on backup locations.

  • Fixes a situation where an Exchange item-level restore would be aborted due to the Altaro management console UI session timing out.

  • Fixes an issue that would cause backup failures or host disconnections on a VMware environment.

  • Other fixes and improvements.



(Follow the steps here to upgrade to the latest version)