Altaro VM Backup requires .NET 4.6.2 or newer as a minimum system requirement. If you are not running .NET 4.6.2 as a minimum, you will need to install it, reboot and then run the Altaro installer once again.


Note:  If TLS 1.0 and 1.1 are disabled on the machine, then .NET 4.7 is required as a minimum. (See also: TLS 1.2 Compatibility Checker Tool)


Pro Tip:  Altaro VM Backup 8.6 or newer checks that .NET Framework 4.6.2 or newer is installed during initial installation.  If .NET Framework 4.6.2 or newer is not detected then the Altaro installer will display a message to the user and abort.


To find .NET Framework versions running 4.5 and later, you can follow these steps here:


  1. Open the Registry Editor, from Run by entering 'regedit'. You must have administrator privileges.

  2. Within the Registry Editor, navigate to the following subkey: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4\Full. If the Full subkey isn't present, then you don't have the .NET Framework 4.5 or later installed.

  3. Check for a DWORD entry named Release. The value is a release key that corresponds to a particular version of the .NET Framework. In the following figure, for example, the value of the Release entry is 528040, which is the release key for .NET Framework 4.8.

    In order to check what versions of .NET Framework you have installed, you can check the versions listed here as documented by Microsoft.



  4. To download the latest .NET versions, see here: https://dotnet.microsoft.com/download/dotnet-framework