PROBLEM


Unable to complete the upgrade to the latest version because of error: "This Application requires Windows Server 2008 R2". 

Windows Server 2008 R2 or later is already installed.




CAUSE


This is a known issue after doing an in-place upgrade from Windows Server 2008 R2 to Windows Server 2012



SOLUTION


Run the "Microsoft Fix It" tool provided here: http://support.microsoft.com/mats/Program_Install_and_Uninstall

Warning: Since this is not an Altaro utility, please use with caution.