PROBLEM


Unable to complete the install the latest version because of error: "This application requires .NET Framework 4.6.2 or later. Please install the .NET Framework then run this installer again".




CAUSE


Altaro VM Backup version 8.6 upwards requires .NET version 4.6.2 or higher.



SOLUTION


Download and install .NET 4.6.2 or later from here: https://dotnet.microsoft.com/download/dotnet-framework 


Note: If installing on Windows Server 2008R2, installation of SP1 is required before installing .NET 4.6.2


Once this is fully installed, you'll be able to proceed with the Altaro installation.