PROBLEM


Unable to complete the install the latest version because of error: "This application requires .NET Framework 4.0 Full version. Please install the .NET Framework then run this installer again".





CAUSE


Altaro VM Backup 7.6 and onward require .NET4.0 installed, even on older Windows Server installations such as 2008R2.



SOLUTION


Download and install .NET4.0 full installation from here: https://www.microsoft.com/en-us/download/details.aspx?id=17851


Once this is fully installed, you'll be able to proceed with the Altaro installation.